¿Has tenido problema al actualizar algún plugin de WordPress?
¿La nueva actualización de WordPress no se instala?
Si el registro de errores de esos plugins o el registro en el servidor está teniendo el mensaje de error fatal de PHP tal como:

“Maximum execution time of 30 seconds exceeded in executing specific line of PHP code”
“Tiempo de ejecución máximo de 30 segundos superó en la ejecución de la línea específica de código PHP”

El problema es un timeout del servidor, te explicamos como resolverlo de una forma sencilla:

WordPress update error
Si las actualizaciones son manuales, el mensaje saldrá en cuanto comience a descomprimir el zip.

El problema es un timeout, así que hay una necesidad de aumentar el valor predeterminado o establecer el tiempo máximo para la ejecución de un proceso en el servidor.

Hay varias maneras de aumentar el tiempo de ejecución de un proceso iniciado. O aumentar ese tiempo añadiendo una línea en el archivo wp-config.php o al .htaccess o php.ini alojado en tu servidor web. No es necesario hacer los tres cambios, en cualquiera de estos funciona bien. Eso significa, que depende de tu conveniencia para elegir cualquiera de estas tres formas de aumentar el establecer el tiempo máximo de ejecución para su servidor.

Para WordPress, es mucho más fácil de hacer que cambiando archivo wp-config.php que está disponible en la raíz de la instalación.

Cambios en el Wp-config.php de WordPress

Simplemente has de añadir esta línea: set_time_limit (60);
Importante – Si va a realizar cambios en wp-config.php, a continuación, agrega esta línea antes de la frase: “/* That’s all, stop editing! Happy blogging. */” o /* ¡Eso es todo, deja de editar! Feliz blogging */ en español.

 

Cambios en el .htaccess de WordPress

Has de añadir esta línea: php_value max_execution_time 60

Cambios en el php.ini de WordPress

Has de añadir esta línea: max_execution_time = 30;
Por experiencia te podemos decir que el más sencillo y que nos ha funcionado es el cambio en el .htacces